BW Studio 6.4 and BW PDK 6.2

Are these two products compatible? I've created a new BW Palette product after installing "TIBCO ActiveMatrix BusinessWorks(TM) Plug-in Development Kit 6.2.0" over TIB_bwce-dev_2.3.4_linux26gl23_x86_64.zip. When I try to create a New Configuration as https://docs.tibco.com/pub/bwpdk/6.2.0/doc/pdf/TIB_bwpdk_6.2_developer's_guide.pdf states I get the following errors in the manifest

 

Require-Bundle: com.mycompany.bw.palette.helloworld.model;bundle-version="1.0.0",
 com.tibco.bw.design;bundle-version="[6.0.0,7.0.0)",
 com.tibco.bw.model.eclipse;bundle-version="[6.0.0,7.0.0)",
 com.tibco.amf.sca.model.validation;bundle-version="[3.901.0,4.0.0)"

Last 3 bundles cannot be resolved.

 

At runtime I get the following:

!ENTRY com.modusbox.bw.palette.partnermanagerconnector.design 4 0 2018-07-11 17:55:46.478
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.modusbox.bw.palette.partnermanagerconnector.design [296]
  Unresolved requirement: Require-Bundle: com.tibco.bw.design; bundle-version="[6.0.0,7.0.0)"

(1) Answer

Login