Connecting from Spotfire Analyst to Spotfire Data Streams Minimal LiveView Sample fails: Unknown protocol

Spotfire Analyst 11.4 and StreamBase Server 10.6

AS per a previous community question, which I tried, I could not get the same result (https://community.tibco.com/questions/how-use-spotfire-data-streams-load-real-time-data-spotfire) I tried adding this comment to the thread with no success despite logging in with a support account.

I started the "sample_lv_sample_helloliveview_application.shonavar" in SB Studio which started the service on TCP port 61647. Also showed in the console and "epadmin display services" and "INFO  com.streambase.sb.sbd.net.StreamBaseHTTPServer: sbd at DC1-SPTFR-PROD:8271; pid=288; version=10.6.1_0a0fdf7f8f3d4f25851d53e0e55c97ce2ece3d22; Listening".

In Spotfire Analyst I tried "Connect To -> New Connection" to "Tibco Spotfire Data Streams" and entered localhost:61647 for Server(also tried http://localhost:61647, (no authentication, TLS or compression), I got a Refused/Closed Connection from server in Spotfire Connect dialog. The Studio Console shows the follwing warning(s) for each attempt I tried.

"(fragment deploy): 2021-11-22 15:50:44.934000-0500 [9052:Thread- ThreadPool - 16] WARN  com.streambase.sb.sbd.net.HTTPServer: Connection /0:0:0:0:0:0:0:1:58714: Unable to determine client protocol version"

On the host netstat, the Node in Studio is Listening on both IPV6 (and IP4) on 61647 and the Spotfire Analyst is trying on the IP4 and node expecting in IP6? 

 

1 Comment

Also, with regard to your statement in the Question:



"I tried adding this comment to the thread with no success despite logging in with a support account"



Two things to mention there:



1) "logging in with a support account"



Accounts for TIBCO Community and TIBCO Support are separate accounts. Having a support account doesn't get you rights on Community and vice versa. Though that wasn't actually why you couldn't add a comment.

2) "I tried adding this comment to the thread" on another Community Answer article from 2019.



Right, the ability to add comments to a Community Answer article expires after a while.

In this case, it's great that you made a new Answer post, because the problem you encountered and wanted to ask about -- in essence, how to I determine what LiveView Client Listen Port my LiveView engine process is using? -- is somewhat separate from the issue addressed in the 2019 article anyway. In general, Community is more useful when it has lots of short Answer posts rather than fewer, longer posts. That is, each post should really be focused on as small an issue as possible.

That said, I went ahead and updated the 2019 article to indicate that you need to know the LiveView Client Listen Port, and that it might not be 10080, and how to find out what it is! (by referencing this post). So thanks, that's an improvement!

sbarber - Nov 23, 2021 - 1:02pm
+ Add a Comment

(1) Answer

Login