"Error installing package: Error in unzip(zipFile): error calling zip command" although no spaces in the temp and tmp vars

I am running Spotfire 10.3 Desktop.

I have changed the environment variables temp and tmp to: C:\TEMP and C:\TMP, respectively.

I also have unzip.exe in my PATH system variable.

 

I am trying to install packages from the package manager menu but I get this error:

Error installing package: Error in unzip(zipFile): error calling zip command

 

Any assistance would be greatly appericiated !!!!

 

 

 

3 Comments

UPDATE: I thought I got it solved, but the problem persists... I cannat find any logic behind the behavior of TERR as sometimes it installs packages correctly, other times it will report an error with unzip, and in others it will just say that it cannot find a package that is already listed as installed.

 

 

I thought this worked, but it didn't:

I uninstalled Spotfire, removed every related folder in appdata folder and temp folders.

Then I re-installed Spotfire and moved the install folder to C:\Spotfire

I then changed the config file to reflect the new location.

This solved the unzip error for Tidyverse.

alavy - Sep 16, 2020 - 10:57am

I am trying to install tidyverse

 

alavy - Sep 16, 2020 - 10:08am

What packages are you attempting to install?

KirstenS - Sep 16, 2020 - 10:04am
View More Comments + Add a Comment

(1) Answer

Login