Python Errors

I appreciate the release of python in the later versions of Spotfire.  However, I get so many errors it has become unusable.  And when I finally solve the errors in my environment, they will randomly re-appear with no clear description of what is happening.

ie see below.  Python 3.7 is downloaded and was working properly and now isn't...............

Python - 3.7.0  is not supported on this machine. Please verify installed Python versions.

   at SpotfirePS.DataFunctions.Python.PythonEngine.GetEngineInfo(String name)

   at SpotfirePS.DataFunctions.Python.PythonDataFunctionExcecutor.<ExecuteFunctionCore>d__2.MoveNext()

   at Spotfire.Dxp.Application.Extension.CustomDataFunctionExecutor.<Spotfire-Dxp-Data-DataFunctions-IFunctionExecutor-ExecuteFunction>d__5.MoveNext()

   at Spotfire.Dxp.Data.DataFunctions.DataFunctionExecutorService.<ExecuteFunction>d__3.MoveNext()

1. Is anyone else experiencing many issues using python within Spotfire?

2. Is there anything in the pipeline to enhance the experience using Python in upcoming releases??

 

please assist.  As of right now I will need to re-write everthing using R.

 

 

 

1 Comment

And now I'm getting this error in TERR.  (was just working)

 'Error in .Call() : Evaluation error: This function should not be called directly

  1. ├─base::tryCatch(...)

  2. └─base::evalq(seq(n()), <environment>)

  3.   └─base::eval(expr, envir, enclos)

  4.     └─base::eval(expr, envir, enclos)

  5.       ├─base::seq(n())

  6.       └─dplyr::n()

jalley - Jun 10, 2019 - 2:34pm ::
+ Add a Comment

(1) Answer

Login