R Error with Data Function Points in Polygons

Hello, 

Yesterday all my projects that are utilizing the Points in Polygons stopped working and received this error message:

Could not execute function call.
TIBCO Enterprise Runtime for R returned an error: 'Error in validObject(res) : invalid class "SpatialPolygons" object: non-unique Polygons ID slot values'.
   at Spotfire.Dxp.Data.DataFunctions.Executors.LocalFunctionClient.OnExecuting()
   at Spotfire.Dxp.Data.DataFunctions.Executors.AbstractFunctionClient.<RunFunction>d__0.MoveNext()
   at Spotfire.Dxp.Data.DataFunctions.Executors.SPlusFunctionExecutor.<ExecuteFunction>d__0.MoveNext()
   at Spotfire.Dxp.Data.DataFunctions.DataFunctionExecutorService.<ExecuteFunction>d__6.MoveNext()

TIBCO Enterprise Runtime for R returned warnings
Loading required namespace: rgdal
Loading required namespace: rgdal
Loading required namespace: rgdal
Loading required namespace: rgdal

TIBCO Enterprise Runtime for R returned warnings
Loading required namespace: rgdal
Loading required namespace: rgdal
Loading required namespace: rgdal
Loading required namespace: rgdal

TIBCO Enterprise Runtime for R returned warnings
Loading required namespace: rgdal
Loading required namespace: rgdal
Loading required namespace: rgdal
Loading required namespace: rgdal

I'm on on version 7.8 and have the latest v1.0 of Points in Polygons. I tried reloading the R packages, restarted, etc. I checked with everyone here, no one made any changes with our database or anything else. 

Anyone know what the error message means or have any idea why it suddenly stopped working?

Any help is greatly appreciated,

Thanks!

Tim

(1) Answer

Login