Spotfire Analyst crashes on startup after building custom Automation Services extension
TIBCO Spotfire®

So, I've been building a custom Automation Services extension the past couple days and launching it via the Package Builder. Yesterday, as I tried to add a `ViewAddIn` Windows Form project to the package, Spotfire Analyst began to crash on `Loading extensions...`. I'll add the details of that crash below.

Package Builder had originally worked up to that point. Since I originally tested Package Builder using the provided `SpotfireDeveloper.AutomationServicesExample` and `AutomationServicesExample.Forms` projects in the SDK, I cleared my configuration of my own project and tried to launch with the example again. Spotfire Analyst now crashed at the same point. 

Then I tried to launch vanilla Spotfire Analyst (without Package Builder), and again it crashed at `Loading extensions...`.

I've been banging my head against this for the past two days. No matter what I do, I cannot get Spotfire Analyst to launch. 

Things I've tried so far:

  • Uninstalling/reinstalling Spotfire Analyst
  • Uninstalling/reinstalling/repairing every version of .NET on my machine (4.5.1 through 4.7.1)
  • Uninstalling every other TIBCO product on my machine (Hawk and Rendezvous)
  • Wiping out %APPDATA%/Local/TIBCO between every reinstall
  • Restarting my machine between every uninstall and reinstall mentioned above
  • Completely wiping out the SDK and Package Builder and trying to launch Analyst vanilla after reinstall
  • Launching Analyst via the `Spotfire.Dxp.exe` provided in the SDK
  • Launching Analyst via an 'empty' configuration in Package Builder after reinstalls
  • Launching Analyst with a Package Builder config pointed at my extension and one built toward the provided example project
  • After reinstall, launching Analyst initially pointed at different Spotfire Server environments (development and acceptance)
  • After reinstall, launching Analyist both without downloading updates (modules) from the server and with downloading them
  • Wiping out the .dlls of my custom extension

No matter what I do, Analyst crashes on `Loading extensions...`. I've tried everything I can think of. I've wiped everything TIBCO off of my machine and installed fresh. The only thing I haven't tried is snooping through the registry. It seems like my messing with custom extensions is still interfering with Spotfire Analyst, but for the life of me I can't find a breadcrumb trail to lead me there.

Below are the (Windows-provided) error details when I try to launch:
 

Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	Spotfire.Dxp.exe
  Problem Signature 02:	28.0.10812.8522
  Problem Signature 03:	58780863
  Problem Signature 04:	System.Core
  Problem Signature 05:	4.7.2563.0
  Problem Signature 06:	5a334ef7
  Problem Signature 07:	abc
  Problem Signature 08:	4d
  Problem Signature 09:	System.InvalidOperationException
  OS Version:	6.1.7601.2.1.0.256.4
  Locale ID:	1033
  Additional Information 1:	2509
  Additional Information 2:	2509dd28966bb148cc3d241768eb8308
  Additional Information 3:	23a7
  Additional Information 4:	23a7c354b7a079dfb1c88b5ccaae3a86

Searching around for CLR20r3 leads to people that have solved the startup issue by reinstalling either Analyst or .NET, but I have done that about ten times with no results.

 

Any help, even just tips on debugging this, would be greatly appreciated. I don't know where Spotfire tries to load extensions from, but that would be helpful. 

Thanks so much!

Attachments

AttachmentSize
Image icon crashes_here.png9.08 KB

3 Comments

Hello Kyle,

Please try to run the exe as a Adminsitrator and see if that helps.

If it still fails please raise with TIBCO Support and also provide the Process Monitor logs and Event viewer logs

Instructions to send us Event Viewer logs:

---------------------------------------------------------------

1). Search for Event Viewer in Windows.

2). Open the Event Viewer application.

3). On the left side panel, select Windows Logs << Application.

4). On the right side panel, select Save All Events As...

<< save the *.ectx file.

5). Attached the saved *.ectx file to the case.

---------------------------------------------------------------

Instructions to send us Process Monitor logs:

---------------------------------------------------------------

1. Download Process Monitor from Microsoft/Sysinternals: http://technet.microsoft.com/en-us/sysinternals/bb896645

2. Shut down any programs you don't need at the moment

3. Start Process Monitor (procmon.exe)

4. Recreate the error

5. Press Ctrl E in Process Monitor to stop capturing events

6. Save the Process Monitor log (File > Save...) in .PML file format and attach to the case.

---------------------------------------------------------------

 

Seema K - Apr 10, 2018 - 6:16pm ::

Unfortunately, the above did not work. There weren't any registry key entries after the uninstall.

Kyle.Johnson - Apr 10, 2018 - 7:55am ::

Try to perform a complete uninstall of the existing client and then install the newer version. Below are the steps to perform a clean uninstall, Note: Make a back up copy of all the files and also the registry before deleting them.

  1). Make sure all TIBCO Spotfire client products are uninstalled using the Control Panel.

2). Delete any remaining files in [Install Directory]\TIBCO.      Example:  C:\Program Files\TIBCO  3). Delete any remaining files in [Install Directory]\TIBCO        Example: C:\Program Files (x86)\TIBCO .

4). Delete any remaining files in C:\Users\<username>\AppData\Local\TIBCO .

5). Delete any remaining shortcuts on the desktop to TIBCO Spotfire.

6). Delete any remaining start menu groups for TIBCO Spotfire.

7). Start regedit and delete “TIBCO” key (if present) in:    

a).  HKEY_CURRENT_USER\Software  

  b).  HKEY_CURRENT_USER\Software\Wow6432Node  

  c).  HKEY_LOCAL_MACHINE\Software  

  d).  HKEY_LOCAL_MACHINE \Software\Wow6432Node

After performing the steps above, you should have a clean system without any references to the previous TIBCO Spotfire installed client. You can now install the new version of the TIBCO and see if this helps

Seema K - Apr 08, 2018 - 7:21pm ::
View More Comments + Add a Comment

(1) Answer

Login