TSSS - Not able to run Open Source R after Configuration with TSSS Engine

Hi There,

 

I just configured the TERR Engine 7.5 to use Open Source R Engine Version 3.2.3. I followed the TERR Administration Guide and also a userful blog: http://bispotfire.blogspot.my/2015/07/configuring-open-source-r.html

However, when I run a simple R function in Spotfire Analyst against TERR Open Source R Engine. I'm getting below error:

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Timed out connecting to http://localhost:8082/TERR/api/v8/administration/ExtendedServerInfo after 10000 ms while downloading manifest. Please verify the URL.
   at Spotfire.Dxp.Data.SPlus.FunctionClient.GetWebResponseWithTimeout(WebRequest request)
   at Spotfire.Dxp.Data.SPlus.FunctionClient.GetWebResponseWithTimeout(String serviceUrl, String resourcePath, String method, ICredentials credentials)
   at Spotfire.Dxp.Data.SPlus.FunctionClient.ValidateCredentials(String serviceUrl, ICredentials credentials)
   at Spotfire.Dxp.Data.DataFunctions.Executors.RemoteFunctionClient.<GetConnectedClient>d__21.MoveNext()
   at Spotfire.Dxp.Data.DataFunctions.Executors.RemoteFunctionClient.<OnInit>d__3.MoveNext()
   at Spotfire.Dxp.Data.DataFunctions.Executors.AbstractFunctionClient.<Initialize>d__b.MoveNext()
   at Spotfire.Dxp.Data.DataFunctions.Executors.AbstractFunctionClient.<RunFunction>d__0.MoveNext()
   at Spotfire.Dxp.Data.DataFunctions.Executors.SPlusFunctionExecutor.<ExecuteFunction>d__0.MoveNext()
   at Spotfire.Dxp.Data.DataFunctions.DataFunctionExecutorService.<ExecuteFunction>d__6.MoveNext()
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

You may refer to the screenshot as attached. 

 

I have also tested the TERR web page and is it loading like normal and can show the home page.

Is there some configuration I miss out? Really appreciate your help.

Thank you.

Cheers,

Wilson Hooi

 

 

(3) Answers

Login