Unable to connect to SQL Server via TIBCO Spotfire Information Designer

I am trying to connect to SQL Server DB via Infromation Designer(set up data source) but it is throwing the below error The TCP/IP connection to the host , port 1433 has failed. Error: "Connection refused: connect. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall." But i am able to connect through SQL Server Management Studio (which is installed in different machine). Also i tried connecting to different DB Server of SQL database and that is successful. Please let me know any configuration needs to be done from Spotfire end.

7 Comments

Go to the Windows start -> All Programs -> Sql Server Configuration Manager on your desktop.  Expand the SQL Server Network Configuration option and select Protols for MSSQLSERVER.  Verify that TCIP/IP is enabled in the panel on the right.

Petrogeek - Apr 05, 2018 - 9:46am
@Shaun- I am not using impersonation in Spotfire. And the login method in SQL is Windows authentication.
akshayabhat23 - Dec 20, 2015 - 11:02pm
Are you using impersonation in your Spotfire deployment?
Shaun Simon - Dec 18, 2015 - 7:24am
Thanks brijesh, Shaun and Addy.

I pinged the DB server and its successful. Login is windows authentication in SQL and checking and checking for the acess permission for my ID.
akshayabhat23 - Dec 17, 2015 - 9:38pm
connection string :
jdbc:sqlserver://<server>:<port>;DatabaseName=<DB Name>;

Add SSL if require, Also check if login is User-id/password not windows authentication on SQL server. And Firewall open for Spot-fire host.
brijesh.kumar - Dec 17, 2015 - 7:23am
Definitely try to ping it first. It's most likely a network access issue versus your credentials.

Also, if that particular SQL server requires SSL you will have to force that in the connection string.

jdbc:tibcosoftwareinc:sqlserver://yourServer:1433;databaseName=yourDB;EncryptionMethod=requestSSL;ValidateServerCertificate=true;
Shaun Simon - Dec 17, 2015 - 6:04am
Try to ping the DB server from the machine where Spotfire is installed to check if it's connecting or firewall is preventing connection.
Addy - Dec 17, 2015 - 3:53am
View More Comments + Add a Comment
Login