TIBCO Spotfire® Database Drivers
Last updated:
6:04am Aug 20, 2018

To enable TIBCO Spotfire® data connectors, download and install drivers listed here.

Often the latest driver version is supported but there are exceptions.

Please review system requirements before selecting driver version to download.

Database Driver TIBCO Spotfire Analyst version Details

Amazon Redshift

7.0 and later, Cloud

Link to Amazon's website.

Attivio 7.7 and later, Cloud The Attivio ODBC driver is downloaded from Attivio. Please see the Spotfire Analyst documentation and navigate to Home > Connectors > Attivio > Loading Data from explore.attivio.com.

Apache Spark SQL

7.5 and later, Cloud

The TIBCO ODBC Driver for Apache Spark SQL is included in TIBCO Drivers®.

Spotfire 7.5 and later

  1. Go to the Spotfire Server page on TIBCO E-delivery, and sign in with your TIBCO account.
  2. Select the software version, your operating system, accept the license agreement, and then click Individual file download.
  3. Click to expand TIBCO Drivers Software, and download the drivers files.

TIBCO Cloud™ Spotfire® 

  1. In your web browser, log in to TIBCO Cloud™ Spotfire®
  2. In the navigation pane to the left, click Downloads.
  3. In the TIBCO Drivers list, click to download the Apache Spark SQL driver.

Additional notes about Apache Spark SQL

Note: Cloudera currently does not support Spark SQL.

Note: Hortonworks supports Spark SQL in HDP 2.3.4 and later.

Note: For a description of MapR's Spark SQL support, see the official MapR documentation here and here.

Note: Apache Spark SQL is included with IBM® Open Platform with Apache Hadoop (part of IBM BigInsights®).

Note: There are currently Kerberos reliability issues in the Spark Thrift server. The use of Kerberos with Apache Spark SQL is therefore not recommended.

 

 

 

Cloudera Hive

6.0 and later, Cloud

Link to the Cloudera's website.

Cloudera Impala

6.0 and later, Cloud

Link to the Cloudera's website.

Hortonworks

6.0 and later, Cloud

Download the driver from Hortonworks:

http://hortonworks.com/downloads/

Locate the Hortonworks ODBC Driver for Apache Hive (scroll down the page to the section Hortonworks Data Platform Add-Ons). Make sure you select the right version of the driver for your operating system (32-bit or 64-bit).

HP Vertica

6.0 and later, Cloud

Download the HP Vertica ADO.NET driver from HPE's myVertica website.

The driver can be downloaded by registered users. Contact your HP account manager for access to this driver.

IBM DB2

6.5 and later, Cloud

Download the IBM DB2 ODBC driver from IBM's website.

The driver can be downloaded by registered users. Contact your IBM account manager for access to this driver.

IBM Netezza

5.5 and later, Cloud

Contact your IBM account manager for access to the IBM Netezza ODBC driver.

Make sure you install the correct version (32-bit or 64-bit) on your system.

Microsoft SQL Server

5.0 and later, Cloud

The driver is included in Microsoft.NET, so there is no need for a separate installation.

Microsoft SQL Server Analysis Services

5.0 and later, Cloud

Install the ADOMD.NET driver, available for download from Microsoft, as part of the feature pack for your version of Analysis Services:

SQL Server Analysis Services 2016

SQL Server Analysis Services 2012

SQL Server Analysis Services 2008

Click Download to enable the selection of individual files in the package. Locate and download the file SQL_AS_ADOMD.msi or SQLSERVER2008_ASADOMD10.msi (depending on the SSAS version) for your operating system bitness (x32 or x64).

OData

7.0 and later, Cloud

No driver installation required.

Oracle

5.0 and later, Cloud

To use the Oracle connector, first install the Oracle Data Access Components (ODAC) appropriate for your system (64-bit or 32-bit):

To download the driver:

  1. In a web browser, go to Oracle's download website.
  2. Under ODAC OUI, click to expand the drop-down menu with driver versions.
  3. Select the desired driver version, and then click the Download button to the right of the drop-down menu. 

Note: You must log in with your Oracle account to start the download. 

Oracle Essbase

6.0 and later, Cloud

To use the Oracle Essbase connector, you must install version 11.1.2.4.0 of the Essbase Client, which is included in Oracle Enterprise Performance Management System version 11.1.2.4.0.

You must also configure certain environment variables on your computer.

Procedure:

  1. Log in with your Oracle account on Oracle Software Delivery Cloud and search for Oracle Enterprise Performance Management System Client Installers 11.1.2.4.0. Select the Microsoft Windows x64 (64-bit) platform version and download the driver. 
  2. Install the Essbase Client and, during the installation, make sure that both Essbase Client and Essbase Client C API are installed.
  3. Set up the following required environment variables on your computer. To create and configure environment variables, go to System Properties, click on the Advanced tab and click Environment Variables…. Under System variables, click New... and add variables with the following names and values:
    • EPMHOME
      Value: The home path for the Oracle Enterprise Management System.
      (Example: C:\oracle\Middleware\EPMSystem11R1\)
    • ARBORPATH
      Value: The path that you specified during the installation of the Essbase Client. 
      (Example: %EPMHOME%\products\Essbase\EssbaseClient\)
    • ESSBASEPATH
      Value: %ARBORPATH%
    • PATH
      Add the following value to the variable (or create the variable it if it doesn’t already exist on your system):
      %ARBORPATH%\bin;%EPMHOME%\bin;

      Note: If possible, create the variables as system environment variables, rather than user environment variables. If you are configuring a computer running Spotfire Web Player services or Automation Services services, the variables must be created as system environment variables.

Oracle MySQL

5.5 and later, Cloud

Download the Oracle MySQL Connector/Net from Oracle's website.

Pivotal Greenplum

6.0 and later, Cloud

Download the Psql ODBC driver from PostgreSQL's website.

Pivotal HAWQ

6.5 and later, Cloud

Download the Psql ODBC driver from PostgreSQL's website.

PostgreSQL

5.5 and later, Cloud

Download the Psql ODBC driver from PostgreSQL's website.

Salesforce

7.5 and later, Cloud

Spotfire 7.14 and later, and TIBCO Cloud™ Spotfire®

In version 7.14 and later of Spotfire, you can use the Salesforce connector without installing any additional software on your computer.

 

Spotfire 7.5 - 7.13

Use the TIBCO ODBC Driver for Salesforce, which is included in TIBCO Drivers®.

  1. Go to the Spotfire Server page on TIBCO E-delivery, and sign in with your TIBCO account.
  2. Select the software version, your operating system, accept the license agreement, and then click Individual file download.
  3. Click to expand TIBCO Drivers Software, and download the drivers files.

SAP HANA

6.0 and later, Cloud

Link to SAP's Software Download Center website.

The driver can be downloaded by registered users. Contact your SAP account manager for access to this driver.

SAP NetWeaver Business Warehouse (SAP BW)

5.5 and later, Cloud

The Spotfire connector for SAP BW supports the following data source drivers, which are available in the Download Software area of the SAP Support Portal.

Spotfire 7.11 and later:

  • SAP NetWeaver RFC SDK (BAPI driver)
  • SAP BW OLE DB for OLAP provider (ODBO driver)

For more information and instructions for installing the required drivers on Spotfire 7.11 and later, see Installing Drivers for the SAP BW Connector.

Spotfire 7.10 and earlier:

  • SAP BW OLE DB for OLAP provider (ODBO driver)

See SAP documentation for information on how to configure the SAP BW servers on your system.

Teradata

5.0 and later, Cloud

Link to Teradata's website.

Teradata Aster

6.0 and later, Cloud

Link to Teradata's website.

Note: Make sure you download the latest released version of the Aster ODBC driver (e.g., included in the "Client Tools" package provided by Teradata). However, the driver is currently not available in each new version of the "Client Tools" package; if you encounter this issue, look for it in a previous version.

TIBCO Data Virtualization 5.5 and later, Cloud No driver instalaltion is required.

Feedback (1)

Attempting to download driver for Apache Spark SQL, but on eDelivery site there are no choices in the dropdown menus for Version and Operating Systems. Link

jjburnam 11:50am Sep. 28, 2016