What versions of TIBCO® Enterprise Runtime for R (TERR) are available?
By:
Last updated:
8:19am Sep 04, 2018

You can easily check which version of TIBCO Enterprise Runtime for R (TERR) is included with the version of your Spotfire installation.

From the Spotfire menu, click Tools > TERR Tools, and then read the path to the local TERR engine that is displayed.  

If you are curious about the Spotfire versions of TERR beyond your particular Spotfire installation, check the following handy short chart, and review the detailed information provided in the table below.

            Note   Some versions of TERR are available for Developer Edition only and are not included
                       in any version of Spotfire. You can download and run these console versions from 
                       TIBCO eDelivery.

Versions of TERR included with Spotfire

Because we are always working toward improving TERR and TERR compatibility with open-source R, we encourage you to update your installation to newer versions if possible.

Note: Not all releases are listed. See the TIBCO® Enterprise Runtime for R documentation for each release on docs.tibco.com for more details. If you are interested in earlier versions, contact TIBCO Spotfire Support.

 

TIBCO Enterprise Runtime for R (TERR) Version

Release Date

TIBCO Spotfire® availability

Comments

R Compatibility

System Requirements (inc. RStudio version)

4.4 Sep 2017 Please contact Support for instructions for upgrading your TERR engine under Spotfire to 4.3.1
  • Further increases in R compatibility and performance improvements.
Reports for Windows, Linux and Mac available on Doc site. System Requirements
4.3.1 May 2017 Please contact Support for instructions for upgrading your TERR engine under Spotfire to 4.3.1

Certain CRAN packages (such as quantreg, igraph, and leaps) would cause the TERR engine used within TIBCO Spotfire® to become unresponsive. This issue also caused problems with the PythonInR package. If you are experiencing hangs in a TERR Data Function when loading a package, you should install 4.3.1

Reports for Windows, Linux and Mac available on Doc site. System Requirements
4.3 Feb 2017

Available via Hotfix for Spotfire 7.0 to 7.8.

Hotfixes are provided from the TIBCO Support site. Once you have logged in there, hotfixes can be found under the Downloads menu > Hotfixes. On the Hotfixes page, Spotfire-hotfixes can be found under "AvailableDownloads" > Spotfire. 

  • Further increases in R compatibility and performance improvements.
  • New Guide to Graphics with TERR.
  • Use TERR in RStudio to create R Markdown Notebooks
Reports for Windows, Linux and Mac available on Doc site. System Requirements
4.2 Aug 2016

Included in Spotfire 7.7.

Spotfire 7.0, 7.5 and 7.6 customers can upgrade to this engine via Hotfix. See Spotfire and Statistics Services Hotfix pages.

Further increases in R compatibility, performance increases and Mac support.  Reports for Windows, Linux and Mac available on Doc site. System Requirements
4.1.1 May 2016

Spotfire 6.5, 7.0, 7.5 and 7.6 customers can upgrade to this engine via Hotfix. See Spotfire and Statistics Services Hotfix pages.

Minor fixes to 4.1. See Release Notes for full details.  Reports for Windows and Linux available on Doc site. System Requirements

4.1

March 2016

Use hotfixes to install 4.1.1.

Huge increases in R package compatibility, including data.table. StatTran package for import and export of SAS(R), JMP(R), SPSS(R), Excel, etc. files

Separate reports for WIndows and Linux available on Doc site.

System Requirements

4.0.2

Jan. 2016

Included in Spotfire and Statistics Services 7.5 and 7.6

Spotfire 6.5 and 7.0 customers can upgrade to this engine via Hotfix. See Spotfire and Statistics Services Hotfix pages. 

Minor bug fixes and R compatibilty improvements. See Release Notes for full details.

Compatibility Report

System Requirements

4.0.1

Nov. 2015

No longer available for Spotfire. Recommend upgrading to most recent version TIBCO Enterprise Runtime for R instead. 

Minor bug fixes and R compatibilty improvements. See Release Notes for full details.

Compatibility report

System Requirements

4.0

Oct. 2015

No longer available for Spotfire. Recommend upgrading to most recent version TIBCO Enterprise Runtime for R instead. 

Current version in Spotfire Cloud

Introduced TRAN repository for packages optimized for TIBCO Enterprise Runtime for R

Compatibility report

System Requirements

3.2

May 2015

No longer available for Spotfire. Recommend upgrading to most recent version TIBCO Enterprise Runtime for R instead. 

Some packages optimized for TIBCO Enterprise Runtime for R deployed to GitHub

Compatibility report

System Requirements

3.1.1

March 2015

Hotfix available to upgrade Spotfire 7.0 and Spotfire 6.5 to use TIBCO Enterprise Runtime for R 3.1.1

Patch done to fix issue with Matrix package. 

Compatibility report

System Requirements

3.1

Jan 2015

Spotfire 7.0

Shipped with Spotfire 7.0 platform

Compatibility report

System Requirements

2.5

May 2014

Spotfire 6.5

Shipped with Spotfire 6.5. Recommend these customers apply a Hotfix to upgrade to a later version of TIBCO Enterprise Runtime for R.

Compatibility Report

System Requirements

2.0

Nov 2013

Spotfire 6.0

Shipped with Spotfire 6.0. Recommend these customers contact support to upgrade to a later version of TIBCO Enterprise Runtime for R. (See KB 45222)

 

System Requirements

1.5

May 2013

Spotfire 5.5

Shipped with Spotfire 5.5. Recommend these customers contact support to upgrade to a later version of TIBCO Enterprise Runtime for R, or upgrade to a later version of Spotfire.

 

System Requirements

 

Feedback (2)

Thanks, jsebby! I've updated the table.

kroan 8:20am Sep. 04, 2018

Would be nice to see the page updated since Spotfire is on 7.14.  I believe it's still TERR 4.4, but this is a handy reference if it's updated.

jsebby 8:02am Sep. 04, 2018