Introducing the all-new TIBCO Community site!

For current users, please click "Sign In" to reset your password and access the enhanced features. If you're a first-time visitor, we extend a warm welcome—click "Sign Up" to become a part of the TIBCO Community!

If you're seeking alternative community sites, explore ibi, Jaspersoft, and Spotfire.

Jump to content

Log file setting for BE process


Manoj Chaurasia

Recommended Posts

Hi,

 

I would like to know how and where I can explicitely set the properties for a BE process, so that I can control the following characteristics.

1. Directory in which BE log file is written

2. Name of the log file

3. Maximum size of the Log file and

4. Maximum number of log file to be created

 

I tried the following 3 methods but all did not work.

 

Method-1:

 

I tried setting the following properties in be-engine.tra file.

1. be.trace.enable true

2. be.trace.term.enable true

3. be.trace.log.enable true

4. be.trace.log.dir c:/logs

5. be.trace.log.maxsize 10000

6. be.trace.log.maxnum 10

7. be.trace.log.append true

After setting these properties, I deployed the application using Tibco Administrator Browser.

 

Method-2:

 

I deployed the EAR file along with deployment configuration XML file with the following text in it, using AppManage.exe utility from command prompt.

<service name="BusinessEvents Archive.bar">

<enabled>true</enabled>

<bindings>

<binding name="BusinessEvents Archive">

<machine>ETEJCVNZ91</machine>

<product>

<type>be-engine</type>

<version></version>

<location></location>

</product>

<description></description>

<contact></contact>

</binding>

</bindings>

<NVPairs name="BE Properties">

<NameValuePair>

<name>be.trace.enable</name>

<value>true</value>

</NameValuePair>

<NameValuePair>

<name>be.trace.log.dir</name>

<value>C:logs</value>

</NameValuePair>

<NameValuePair>

<name>be.trace.log.enable</name>

<value>true</value>

</NameValuePair>

<NameValuePair>

<name>be.trace.log.maxnum</name>

<value>10</value>

</NameValuePair>

<NameValuePair>

<name>be.trace.log.maxsize</name>

<value>10000000</value>

</NameValuePair>

</NVPairs>

<failureCount>0</failureCount>

<failureInterval>0</failureInterval>

<isFt>false</isFt>

</service>

 

Method-3:

 

I tried changing the values of the same attributes using Tibco Administrator browser and redeployed.

 

But, when I tried all the avove-mentioned methods, it is always writing the log files into the default directory as given below.

"tibcotradomainLocalDomainapplicationlogs"

 

Any help to fix this problem is greately appreciated.

Link to comment
Share on other sites

  • 12 years later...
×
×
  • Create New...