Introducing the all-new TIBCO Community site!

For current users, please click "Sign In" to reset your password and access the enhanced features. If you're a first-time visitor, we extend a warm welcome—click "Sign Up" to become a part of the TIBCO Community!

If you're seeking alternative community sites, explore ibi, Jaspersoft, and Spotfire.

Jump to content

TIBCO Hawk rule for queue monitoring whose Monitoring Interval is not working as expected


Recommended Posts

Hi All,

I have kept Hawk rule queue monitoring for two queues ( 4 rules to gether) for the below conditions :

1.) Pending message count >=2 ( Monitoring interval 300 seconds )

2.) (NOT(inboundTotalMessages Increase 0)) (Monitoring Interval86400 seconds ( 24 Hours))

But the first condition working as expected for both the queues and the second condition is not working as expected, that is for the queues its triggering if no data through it with in 10 or somtime 14 Hours Monitoring interval ( in actual it should b 24 Hours)

a.) I have checked if any HMA running behind creating the Issue - NO

b.) Kept over ruling conditions to give priority to the second condition - Still the same issue.

c.) Created as separate rule instead of sub rules under same rule - Still the same issue

d.) cleared the auto config and recreated the Hawk rules - Still the same issue

e.) Checked the HAWK logs and could find no errors/issue with the rules

f.) Checked the server time zones/timings and its the same.

 

Apart from these, is there any input or thaughts which you can share and that would help me to identify an hidden error/cause fo this

 

Environment details :

TIBCO Hawk-4.9.0

TIBCO TRA-5.7.4

TIBCO EMS 6.3.0

TIBCO ActiveMatrix Business Works5.9.3 with HF-5

 

Thanks,

Raja.T.

Link to comment
Share on other sites

  • 4 years later...
×
×
  • Create New...