Introducing the all-new TIBCO Community site!

For current users, please click "Sign In" to reset your password and access the enhanced features. If you're a first-time visitor, we extend a warm welcome—click "Sign Up" to become a part of the TIBCO Community!

If you're seeking alternative community sites, explore ibi, Jaspersoft, and Spotfire.

Jump to content

BPM 4.3.1 User Task Pageflow not opening


Tim Pitman

Recommended Posts

Hello,

I have a simple user task that opens a pageflow that follows a long processof forms and rest calls to BW and logic for branching. It's been in production for a couple years now and has been working just fine. Recently, though, I needed to update the pageflow and create a new branch. I created the branch and deployed to the lower environment. However whenever I try to open the task, it refuses to open. I get the following error in Openspace: "Thursday, January 27, 2022 3:00:21 PM : Failed to open next work item (Failed to open work item [359])". I also see the below error in the BPMNode log. Just to be sure, I downloaded the daa file of the current pageflow that's in our Production environment and deployed it to our lower environment, but it yielded the same results. I also tried deploying it back to the version that was in the lower environment before I updated it, and it still yields the same result. The below error makes it sound like it doesn't have the authority to open the pageflow of the given task, but the task is offered to the user I'm trying to open it with, so why wouldn't it allow them to also call the pageflow

Note: Several months ago, we upgraded from 4.3.0 to 4.3.1. As far as I know this is the first dpeloyment we are having in any environment since then. I tried installing the 4.3.1 version of Designer Studio and tried deploying from there in case it's something weird with the developer tool, but it still wouldn't open. I even created a quick, very simple projectwith a pageflow user task, and it still wouldn't open. Could it be something with the environment

Any help would be appreciated! I have attached the entire project below with the pageflow that has been modified. I even included the BPMNode logs that captured the below error.

 

27 Jan 2022 15:00:21,701 [httpConnector_28] [ERROR] com.tibco.openspace.common.server.utils.CommonLogger - [ERROR] - {OS_ERROR_LOG} - error log {nodeName=`BPMNode1`, severity=`ERROR`, messageText=`com.tibco.n2.wp.services.InternalServiceFault: com.tibco.n2.pfe.services.InternalServiceFault: Unauthorised API call [unauthorised API call ]

Caused by: com.tibco.n2.pfe.internal.exception.PageFlowExecutionException (com.tibco.n2.pfe.services.InternalServiceFault: Unauthorised API call [unauthorised API call ])

Caused by: com.tibco.n2.pfe.services.InternalServiceFault (Unauthorised API call [unauthorised API call ])

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...