Jump to content

OAuth 2.0 authentication issue while invoking REST Service


Recommended Posts

In my application I need to invoke a REST Service using Token for OAuth 2.0 type Authorization.

I have tested the same REST service using Token for OAuth 2.0 type Authorization in PostMan application where I have added that Authorization data to the Request Header at PostMan.

I got the response back from that REST Service.

I have tried the same configuration in Tibco BW 5.14, but BW is showing following error

<?xml version = "1.0" encoding = "UTF-8"?>

<ns0:RESTOutput xmlns:ns0 = "http://www.tibco.com/namespaces/tnt/plugins/json">

  <StatusCode>401</StatusCode>

  <msg>{"detail":"Not authenticated"}</msg>

</ns0:RESTOutput>

I have tried all possible combinations of placing Token in Tibco BW, but every time I am getting same failure response. It looks like I am missing a configuration. I am not sure.

I have attached the BW REST invoking screen shots as well as REST Service invocation screen shots through PostMan for your reference.

It would be really helpful if any one can share his/her suggestion to solve this issue.

Link to comment
Share on other sites

  • 3 weeks later...
×
×
  • Create New...