Jump to content

Problem with empty field


Recommended Posts

I have a problem with a dataset I've been given. Some of the columns have many empty fields (as expected), but I can't select these empty fields. Spotfire also doesn't recognise them as '(Empty)'. I've tried to identify the empty field with the following calculated column:

case  

    when [brandstof_2] is Null then "NULL" 

    when [brandstof_2]=NULL then "NULL" 

    when [brandstof_2]=" " then "spatie" 

    when [brandstof_2]="" then "niks" 

    when [brandstof_2]=' ' then "spatie" 

    when [brandstof_2]='' then "niks" 

else [brandstof_2]

end

If the field brandstof_2 is empty, the calculated column is then also empty, not "NULL" or "spatie" or "niks".

All I know is that the empty field has a length of 1.

Does anyone know how I could fix this? Thanks in advance!

Link to comment
Share on other sites

I tried your calculated column on a test table and it filled it with 'NULL'.

Have you tried looking at the column statistics (click on the 'Data in analysis' icon on the left that looks like a notebook, select your column in the list, then click on the cog rather than the bulb. You should see a section called 'Empty values' that says 'your column has xxx empty values'. See screenshot (I renamed one of my columns to brandstof_2). This also gives the option to replace empty values.

If this does not work, could you post a sample dxp with the dataset?

image.thumb.png.efd8a001359a204855f6091d73246438.png

Link to comment
Share on other sites

×
×
  • Create New...