Jump to content

Send HTTP Request works in Tibco ActiveMatrix BusinessWorks 5.13 but does not for Tibco ActiveMatrix BusinessWorks 5.15


Sean Blackmon 2

Recommended Posts

I have two versions of Tibco Designer one is 5.13 and one is 5.15. I have a simple HTTP call that goes out and comes back with 'Success' when used in Tibco Designer 5.13 however when I send that same request using Tibco Designer 5.15 I get 'An exception was thrown while trying to send the Http request'. The code is identical, I exported it from version 5.13 to version 5.15. Only thing I could think of is in the request that I send there is "&" in it that could be the problem but I tried various methods to escape it, but it still throws same error.

Link to comment
Share on other sites

Here is the full exception that comes back:

<?xml version = "1.0" encoding = "UTF-8"?>

<ns0:ErrorReport xmlns:ns0 = "http://www.tibco.com/pe/EngineTypes">

<StackTrace>Job-103000 Error in [Test/HTTPTEst.process/CDMSAPI-Select] The Http Server replied with a 4XX status code at com.tibco.plugin.share.http.client.JakartaHttpTransportDriver$RequestExecutor.run(Unknown Source) at com.tibco.pe.util.ThreadPool$ThreadPoolThread.run(Unknown Source)</StackTrace>

<Msg>The Http Server replied with a 4XX status code</Msg>

<FullClass>com.tibco.plugin.share.http.client.HttpClientException</FullClass>

<Class>HttpClientException</Class>

<ProcessStack>Test/HTTPTEst.process/CDMSAPI-Select</ProcessStack>

<MsgCode>BW-HTTP-100000</MsgCode>

<Data>

<ns1:HttpClientException xmlns:ns1 = "http://schemas.tibco.com/bw/plugins/http/5.0/httpExceptions">

<msg>The Http Server replied with a 4XX status code</msg>

<msgCode>BW-HTTP-100000</msgCode>

<ns2:statusLine xmlns:ns2 = "http://schemas.tibco.com/bw/plugins/http/5.0/cio">

<httpVersion>HTTP/1.1</httpVersion>

<statusCode>400</statusCode>

<reasonPhrase>Bad Request</reasonPhrase>

</ns2:statusLine>

<ns2:httpMessage xmlns:ns2 = "http://schemas.tibco.com/bw/plugins/http/5.0/cio">

<headers>

<date>Tue, 24 Oct 2023 18:43:37 GMT</date>

<content-length>186</content-length>

<server>Microsoft-IIS/10.0</server>

<x-powered-by>ASP.NET</x-powered-by>

<content-type>application/json; charset=utf-8</content-type>

<connection>close</connection>

</headers>

<binaryContent>eyJlcnJvcnMiOnsia2V5VHlwZSI6WyJLZXlUeXBlIGlzIHJlcXVpcmVkLiIsIiBpcyBub3QgYSB2YWxpZCBLZXlUeXBlLiJdfSwidGl0bGUiOiJPbmUgb3IgbW9yZSB2YWxpZGF0aW9uIGVycm9ycyBvY2N1cnJlZC4iLCJzdGF0dXMiOjQwMCwidHJhY2VJZCI6IjM2Yzk2NzE2LTA1NzQtNDRiOS1hYjkyLTRjZWRmZmM5ODUxOSJ9</binaryContent>

</ns2:httpMessage>

</ns1:HttpClientException>

</Data>

</ns0:ErrorReport>

Part of me is thinking that maybe a jar is missing in 5.15 that is in 5.13 but I'm not able to see any differences in the jars other then the sizes.

Link to comment
Share on other sites

Looks like something has changed in the outbound request from BW 5.15 that the server is not liking. Here is what I suggest you do -

Capture the outbound request (headers+body) from both the versions and see what is different in the BW 5.15 request. Do a base64 decode of the 'binaryContent' value for more information on why the request is being rejected and check if anything specific to the BW 5.15 request is causing it.

Link to comment
Share on other sites

Hello Kurian,

Yeah that is what is strange. I use the exact same request in BW 5.15 and I get back success message. The binaryContent decodes to {"errors":{"keyType":["KeyType is required."," is not a valid KeyType."]},"title":"One or more validation errors occurred.","status":400,"traceId":"36c96716-0574-44b9-ab92-4cedffc98519"}. So after talking to our client they were able to confirm that the '&' in the request is why they are rejecting it on there end. Strange thing is we are pushing out just '&' according to what I see in designer. I have attached some screen shots to see if this will help clear up any doubts. Just a question though do you know if the encoding in Tibco BW 5.15 is different then what is in BW 5.13?

Thanks,

Sean

Link to comment
Share on other sites

×
×
  • Create New...