Introducing the all-new TIBCO Community site!

For current users, please click "Sign In" to reset your password and access the enhanced features. If you're a first-time visitor, we extend a warm welcome—click "Sign Up" to become a part of the TIBCO Community!

If you're seeking alternative community sites, explore ibi, Jaspersoft, and Spotfire.

Jump to content

Running bwce in a Docker swarm: can't access published port.


Recommended Posts

Hi.

I'm having troubles running bwce containers in a docker swarm.

My test container is a simple HTTP GET service that displays the current time (I've uploaded it to docker hub)

docker pull olifly/bwce-time

 

Running it as a standaline container works fine:

docker run -p 8080:8080olifly/bwce-time

 

Running it as a docker swarm service doesn't work however:

docker service create -p 8080:8080 --with-registry-auth olifly/bwce-time

 

I'm unable to access the service on port 8080. The connection simplytimes out.

Creating a service with a nginx container works as it should:

docker service create -p 8080:80--with-registry-auth nginx:latest

 

 

Has anyone had any success with runnintg bwce container in a docker swarm

docker version output:

Client:

Version: 17.09.0-ce

API version: 1.32

Go version: go1.8.3

Git commit: afdb6d4

Built: Tue Sep 26 22:41:23 2017

OS/Arch: linux/amd64

Server:

Version: 17.09.0-ce

API version: 1.32 (minimum version 1.12)

Go version: go1.8.3

Git commit: afdb6d4

Built: Tue Sep 26 22:42:49 2017

OS/Arch: linux/amd64

Experimental: false

 

 

Best regards,

Olafur.

Link to comment
Share on other sites

Hi olafurf,

 

Can you try one of the following things:

 

Change the mode to host

Create a new property, you can name it whatever you want and set it equal to 0.0.0.0. Change the value of your host under your httpConnResource to this new property.

 

Let me know if either of those resolve your issue.

Thanks, Cris

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...
  • 1 year later...

Hi everybody! For me the creation of a new property did not worked. Just only worked fine when I put a "hard code" in the HOSTNAME of HttpConnectionResource (0.0.0.0).

 

Is there any solution for this issue Should we use that "hard code" really (host=0.0.0.0)

 

P.S.: When I put a property in the HOSTNAME, BusinessStudio raise an error, saying that the value of property can't be "localhost", even if the value is other, even if the value is 0.0.0.0. Our BWCE version is 2.4.3.

Link to comment
Share on other sites

×
×
  • Create New...