Introducing the all-new TIBCO Community site!

For current users, please click "Sign In" to reset your password and access the enhanced features. If you're a first-time visitor, we extend a warm welcome—click "Sign Up" to become a part of the TIBCO Community!

If you're seeking alternative community sites, explore ibi, Jaspersoft, and Spotfire.

Jump to content

Stored procs not running on Business studio and the our bpm runtime


Recommended Posts

Hi I have an issue i am trying to run a stored procedure from a database activity task and when i deploy its throwing an error.

I tried to run it from business studio and its also throwing an error there.

When i run it on the db itself it works. may you please point me in the rught direction as to what might be wrong

The error on the bpm logs is: Exception Cause is [null] Exception Message is [1] Exception Stack is [java.lang.ArrayIndexOutOfBoundsException: 1 at com.tibco.bx.extension.database.core.JDBCCommon.getActivityParameters(JDBCCommon.java:3440) at com.tibco.bx.extension.database.core.JDBCCallActivity.setConfigParms(JDBCCallActivity.java:124) at com.tibco.bx.extension.database.core.DatabaseTaskActivity.doWork(DatabaseTaskActivity.java:177) at com.tibco.bx.extension.database.core.DatabaseTaskActivity.eval(DatabaseTaskActivity.java:106) at com.tibco.bx.core.behaviors.activity.BxExtensionBehavior.doEval(BxExtensionBehavior.java:163) at com.tibco.bx.core.behaviors.activity.BxActivityBaseBehavior.eval(BxActivityBaseBehavior.java:913) at com.tibco.bx.core.behaviors.activity.BxActivityBaseBehavior.eval(BxActivityBaseBehavior.java:1) at com.tibco.pvm.infra.api.impl.util.director.IpmEventDirectorBase.handleModelEvent(IpmEventDirectorBase.java:232) at com.tibco.pvm.infra.api.impl.util.director.IpmEventDirectorBase.handleEvent(IpmEventDirectorBase.java:113) at com.tibco.pvm.infra.support.work.impl.WorkItemAbstract.execute(WorkItemAbstract.java:206) at com.tibco.pvm.db.persist.services.engine.IdbSTWorkRunnable.doWorkBlock(IdbSTWorkRunnable.java:134) at com.tibco.pvm.infra.services.engine.impl.STWorkRunnable.run(STWorkRunnable.java:54) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) ]

 

 

and on Business studio it says: The value is not set for the parameter number 1.

Link to comment
Share on other sites

  • 9 months later...
×
×
  • Create New...