Jump to content
We have recently updated our Privacy Statement, available here ×

OpenSpirit Scan for Studio 7.0.0 (Setup Wizard ended prematurely)


James Drain

Recommended Posts

Hi there, hopefully someone can help.

I'm installing Scan for Studio 7 via the MSI provided. I've ensured the pre-reqs are installed first, namely:

Studio Manager 2018

OpenSpirit Runtime 4.3

OpenSpirit Scan Utility 2016 (not the engine, although I have tried with this and get the same error)

Unfortunately towards the end of the installation, I get the error that "TIBCO OpenSpirit Scan for Studio v7.0.0 (x64) Setup Wizard ended prematurely"

Inside the MSI logfile I can clearly see that one of the Custom Actions in the installer is struggling:

Hello, I'm your 32bit Elevated Non-remapped custom action server.

SFXCA: Extracting custom action to temporary directory: C:WINDOWSInstallerMSI6901.tmp-

SFXCA: Binding to CLR version v4.0.30319

Calling custom action OpenSpiritStudioIndexerCA!OpenSpiritStudioIndexerCustomAction.CustomActions.InstallPlugins

Begin InstallPlugins

CurrentDirectory = C:WINDOWSInstallerMSI6901.tmp-

STUDIOMANAGERINSTALLLOCATION = C:Program FilesSchlumbergerStudio Manager 2018

INSTALLSCOPE = perMachine

INSTALLLOCATION = C:Program FilesSchlumbergerStudio Manager 2018ExtensionsTIBCOScan for Studio

ProductCode = {C8D67381-6FDD-4004-8E7C-E82BBFDE0E19}

Exception thrown by custom action:

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ComponentModel.Win32Exception: The system cannot find the file specified

at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)

at System.Diagnostics.Process.Start()

at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)

at OpenSpiritStudioIndexerCustomAction.CustomActions.getInstalledPluginId(String studioManagerInstallLocation, String pluginName)

at OpenSpiritStudioIndexerCustomAction.CustomActions.InstallPlugins(Session session)

--- End of inner exception stack trace ---

at System.RuntimeMethodHandle.InvokeMethod(Object target, Object arguments, Signature sig, Boolean constructor)

at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object parameters, Object arguments)

at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture)

at Microsoft.Deployment.WindowsInstaller.CustomActionProxy.InvokeCustomAction(Int32 sessionHandle, String entryPoint, IntPtr remotingDelegatePtr)

CustomAction InstallPlugins returned actual error code 1603

 

As I'm in a development environment, I have not connected to a live licence server, nor have I run any of the pre-requisite software before. In fact I'm only installing this in an isolated environment for the purposes of packaging the app for deployment.

I'm wondering if anyone can help Why would this be failing with the fresh source clean install

I'm curious to know if the impact of the "32bit Custom Action" running a 64bit file (and location) but don't think that is it.

On digging into the documentation I've found various things to look at, including rights to various Studio*.exe.config files, but even after giving packages/users/trusted installer rights, I'm getting the same error. I'm an administrator on both the machines I've tested it on, and used Group Policy elevation as well as elevating install in other ways to no avail.

Desperate for some help! Thanks in advance.

Link to comment
Share on other sites

  • 4 months later...
×
×
  • Create New...