Jump to content
We have recently updated our Privacy Statement, available here ×

BW 5x backward compatibility


Ray Hindman

Recommended Posts

We are running BW 5.11 engines in production.

We are required to upgrade the servers to run the BW 5.14 runtime.

Is is supported to deploy a BW 5.11 ear file into a server that has BW5.14 installed

In essence; it the BW 5.14 runtime backwardly compatible with engines (ear files) built and validated with 5.11

Link to comment
Share on other sites

Typically, this should work with no issues. However, the ideal approach is to open the project in 5.14, rebuild the EAR file and redeploy it. That would resolve an issues. If you don't have the source code for the EAR file, look in the "data files" in your deployment server and find the project root. You can open that in 5.14 in Designer and rebuild the EAR file.
Link to comment
Share on other sites

Hi Ray, hope you're keeping well.

the official answer for your question should be based on the release notes and the upgrade steps there.

A good practice is to file a Case with TIBCO Support and make them aware of your Go Live plans with the new version.

having said that, in my experience, this has worked just fine. Again, every environment is unique and depends on what activities/features being used. So always have a regression in place as part of the upgrade exercise.

HTH,

Link to comment
Share on other sites

×
×
  • Create New...