Introducing the all-new TIBCO Community site!

For current users, please click "Sign In" to reset your password and access the enhanced features. If you're a first-time visitor, we extend a warm welcome—click "Sign Up" to become a part of the TIBCO Community!

If you're seeking alternative community sites, explore ibi, Jaspersoft, and Spotfire.

Jump to content

TIBCO Businessworks Container Edition Unable to create base image for BW CE using Docker tool Box


Recommended Posts

I am using Docker tool box for my windows 10 operating system because i can not install docker for desktop as windows 10 pro is a prerequite for docker for Desktop version its saying.

In docker tool box which i installed on windows 10 when i am trying to create base image its getting error out with400 Bad Request

below is the error any suggestions

Starting "default"...

(default) Check network to re-create if needed...

(default) Windows might ask for the permission to configure a dhcp server. Sometimes, such confirmation window is minimized in the taskbar.

(default) Waiting for an IP...

Machine "default" was started.

Waiting for SSH to be available...

Detecting the provisioner...

Started machines may have new IP addresses. You may need to re-run the `docker-machine env` command.

Regenerate TLS machine certs Warning: this is irreversible. (y/n): Regenerating TLS certificates

Waiting for SSH to be available...

Detecting the provisioner...

Copying certs to the local machine directory...

Copying certs to the remote machine...

Setting Docker configuration on the remote daemon...

## .

## ## ## ==

## ## ## ## ## ===

/"""""""""""""""""___/ ===

~~~ {~~ ~~~~ ~~~ ~~~~ ~~~ ~ / ===- ~~~

______ o __/

__/

___________/

docker is configured to use the default machine with IP 192.168.99.100

For help getting started, check out the docs at https://docs.docker.com

 

Start interactive shell

ipsit@DESKTOP-BFFG2UJ MINGW64 /c/Program Files/Docker Toolbox

$ cd ..

ipsit@DESKTOP-BFFG2UJ MINGW64 /c/Program Files

$ cd ..

ipsit@DESKTOP-BFFG2UJ MINGW64 /c/Program Files/tibco/bwce/bwce/2.5/docker

$ docker build -t tibco/bwce:latest .

Sending build context to Docker daemon 232.6MB

Step 1/7 : FROM debian:stretch-slim

stretch-slim: Pulling from library/debian

7d2977b12acb: Already exists Digest: sha256:583e0a6588d4eb8cf90baf75dc2d22ebe47765891dfd006c4edf0247add9019b

Status: Downloaded newer image for debian:stretch-slim

---> 3718ed702ef5

Step 2/7 : LABEL maintainer="TIBCO Software Inc."

---> Running in 2f76cd5479ce

Removing intermediate container 2f76cd5479ce

---> 332d42bb1fa1

Step 3/7 : ADD . /

---> b15af0f1dca4

Step 4/7 : RUN chmod 755 /scripts/*.sh && apt-get update && apt-get --no-install-recommends -y install unzip ssh net-tools && apt-get clean && rm -rf /var/lib/apt/lists/*

---> Running in cabeb398e01c

Ign:1 http://deb.debian.org/debian stretch InRelease

Get:2 http://deb.debian.org/debian stretch-updates InRelease [93.6 kB]

Get:3 http://deb.debian.org/debian stretch Release [118 kB]

Get:4 http://deb.debian.org/debian stretch Release.gpg [2410 B]

Get:5 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]

Get:6 http://deb.debian.org/debian stretch-updates/main amd64 Packages [28.2 kB]

Get:7 http://deb.debian.org/debian stretch/main amd64 Packages [7083 kB]

Get:8 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [529 kB]

Fetched 7948 kB in 4s (1874 kB/s)

Reading package lists...

Reading package lists...

Building dependency tree...

Reading state information...

The following additional packages will be installed:

libbsd0 libedit2 libgssapi-krb5-2 libk5crypto3 libkeyutils1 libkrb5-3

libkrb5support0 libncurses5 libprocps6 libssl1.0.2 libwrap0 openssh-client

openssh-server openssh-sftp-server procps ucf

Suggested packages:

krb5-doc krb5-user keychain libpam-ssh monkeysphere ssh-askpass molly-guard

rssh ufw zip

Recommended packages:

krb5-locales libgpm2 tcpd xauth libpam-systemd ncurses-term psmisc

The following NEW packages will be installed:

libbsd0 libedit2 libgssapi-krb5-2 libk5crypto3 libkeyutils1 libkrb5-3

libkrb5support0 libncurses5 libprocps6 libssl1.0.2 libwrap0 net-tools

openssh-client openssh-server openssh-sftp-server procps ssh ucf unzip

0 upgraded, 19 newly installed, 0 to remove and 0 not upgraded.

Need to get 4423 kB of archives.

After this operation, 14.4 MB of additional disk space will be used.

Get:1 http://deb.debian.org/debian stretch/main amd64 libbsd0 amd64 0.8.3-1 [83.0 kB]

Err:2 http://deb.debian.org/debian stretch/main amd64 libncurses5 amd64 6.0+20161126-1+deb9u2

400 Bad Request

Get:3 http://deb.debian.org/debian stretch/main amd64 libedit2 amd64 3.1-20160903-3 [84.8 kB]

Err:4 http://deb.debian.org/debian stretch/main amd64 libkeyutils1 amd64 1.5.9-9

400 Bad Request

Get:5 http://deb.debian.org/debian stretch/main amd64 libkrb5support0 amd64 1.15-1+deb9u1 [61.9 kB]

Get:6 http://deb.debian.org/debian stretch/main amd64 libk5crypto3 amd64 1.15-1+deb9u1 [119 kB]

Get:7 http://deb.debian.org/debian stretch/main amd64 libkrb5-3 amd64 1.15-1+deb9u1 [311 kB]

Get:8 http://deb.debian.org/debian stretch/main amd64 libgssapi-krb5-2 amd64 1.15-1+deb9u1 [155 kB]

Get:9 http://deb.debian.org/debian stretch/main amd64 libssl1.0.2 amd64 1.0.2u-1~deb9u1 [1304 kB]

Get:10 http://deb.debian.org/debian stretch/main amd64 openssh-client amd64 1:7.4p1-10+deb9u7 [780 kB]

Get:11 http://deb.debian.org/debian stretch/main amd64 openssh-sftp-server amd64 1:7.4p1-10+deb9u7 [39.5 kB]

Get:12 http://deb.debian.org/debian stretch/main amd64 libprocps6 amd64 2:3.3.12-3+deb9u1 [58.5 kB]

Get:13 http://deb.debian.org/debian stretch/main amd64 procps amd64 2:3.3.12-3+deb9u1 [250 kB]

Get:14 http://deb.debian.org/debian stretch/main amd64 ucf all 3.0036 [70.2 kB]

Get:15 http://deb.debian.org/debian stretch/main amd64 libwrap0 amd64 7.6.q-26 [58.2 kB]

Get:16 http://deb.debian.org/debian stretch/main amd64 openssh-server amd64 1:7.4p1-10+deb9u7 [332 kB]

Get:17 http://deb.debian.org/debian stretch/main amd64 ssh all 1:7.4p1-10+deb9u7 [189 kB]

Get:18 http://deb.debian.org/debian stretch/main amd64 net-tools amd64 1.60+git20161116.90da8a0-1 [248 kB]

Get:19 http://deb.debian.org/debian stretch/main amd64 unzip amd64 6.0-21+deb9u2 [172 kB]

Fetched 4317 kB in 6s (660 kB/s)

E: Failed to fetch http://deb.debian.org/debian/pool/main/n/ncurses/libncurses5_6.0+2016112... 400 Bad Request

E: Failed to fetch http://deb.debian.org/debian/pool/main/k/keyutils/libkeyutils1_1.5.9-9_a... 400 Bad Request

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing

The command '/bin/sh -c chmod 755 /scripts/*.sh && apt-get update && apt-get --no-install-recommends -y install unzip ssh net-tools && apt-get clean && rm -rf /var/lib/apt/lists/*' returned a non-zero code: 100

ipsit@DESKTOP-BFFG2UJ MINGW64 /c/Program Files/tibco/bwce/bwce/2.5/docker

$

Link to comment
Share on other sites

  • 2 weeks later...
×
×
  • Create New...